Maya Foundations –
Playing with Curves and NURBS and 3D painting
Jean-Marc Gauthier - All Rights Reserved Spring 2005

Same tools different settings. A goofy character painted with Maya's 3D brushes…

… or a fantastic city designed for interactive explorations.
This tutorial shows several methods to create NURBS objects and to paint on NURBS primitives.

Plan of the tutorial:
Part 1 - Playing with Curves
  Creating curves
  Creating surfaces from curves

Part 2 - Using sculpting tools:
  Loft,
  Birail,
  Sculpt Push/Pull,
  Deform lattice

Part 3 - 3D Paint tool and Paint Effects tool
  A- Using the 3DPaint tool
  B- Using the Paint Effects tool

Part 4 - Export to Virtools (for Virtual Spaces applications)
  Ungroup > Combine
  Convert to Polygons
  Export to Virtools
    • Meshes terrain NURBS / PaintEffects brush strokes
    • Textures
Part 1 – Playing with curves and creating surfaces, NURBS
This tutorial will help you to get more familiar with the power of NURBS. The tutorial covers several ways to model and edit curves and NURBS surfaces.

Curves
Let’s start a model from scratch. Step 1 Go to Panels > Edit Layout > Three Panes.
Step2 Go to Modeling > Create > CV Curve Tool
Click point by point to draw a curve in the side view.

After drawing the curves, go to Edit Curves > Curve editing tool and try the manipulators in order to change the curvature in many points of the curve. Please note that you can copy paste one curve in order to get two curves that share similar profiles.

Surfaces
Go to Surface > Loft. Lofting two curves creates a surface. You can create an irregular surface using the Birail tool:
First, create a third curve, curve #3, connecting curve #1 and #2. Hold the "c" key in order to snap the starting point of curve #3 to the nearest points of curve #1 and the ending point of curve #3 to the nearest points of curve #2.

Go to Surface > Birail, select in the order curve #3, curve #1, and curve #2.

You can add detail to your model by adding curves to the NURBS surface.
Step 1, in Modeling, press “select by component” button > press “select by component LINE” button. Step 2, in the 3D window, click and drag an existing curve on the surface. Confirm the surface, step 3, go to Edit NURBS > Insert Isoparm.

In order to edit the surface, press “select by component” button > press “select by component LINE” button, go to Edit Curves > Curve Editing Tool.
This illustration shows a NURBS surface, top, and its polygonal counterpart, bottom.

When creating 3D interactive content, you need to convert the NURBS geometry to polygons before exporting the 3D object to Virtools.

First, save your project!!!! Select the object, press the "Select by Object Type " button, object shows up with green lines.

Go to Modeling > Modify > Convert choose NURBS to Polygons. Please note that you get two objects after conversion: a NURBS object and a polygonal object. The polygonal object CANNOT be converted back into NURBS.

Converting a NURBS surface into Polygons
Part 2- Sculpting tools

We will cover several ways to sculpt a NURBS object: sculpting tools are under Modeling and with deformers are under Animation.

Start from a NURBS sphere primitive in order to create a face,
Start from a NURBS plane primitive in order to create a billboard or a terrain.

Step 1, in Modeling, Create > NURBS Primitives,

choose a sphere in order to create a face,

choose a plane in order to create a billboard or a terrain.
Step 2, make sure that your object is selected, press the "Select by Object Type" button, object shows up with green lines.

go to Edit NURBS > Sculpt Surface Tool, select the tool options (click the square next to the words).
Step 3, in the tool attributes window, select #1 brush type, #2 brush radius, #3 push and pull types, #4, a jpg image to create a new brush.
Step 4, select the NURBS object, press "select by object type" button, object shows up with green lines, and sculpt the object

Sculpting. Please note that you need to adjust the radius of the interactive sculpting tool with the size of the mesh of the plane
Add isoparms curves for more details. Use the curve editing tool for finer details. See part 1 of this tutorial for step by step.

Using Deform lattice:
In Animation, select the NURBS object, make sure that your object is selected, press the “Select by Object Type” button, object shows up with green lines.
Go to Deform > Create Lattice > lattice Options, create
Press “select by component” button > “select by component: points” button > select edges of the divisions of the lattice > select the move tool > move the selected points, the corresponding part of the 3D model is also moving.

**Part 3- 3D paint tool and Paint Effects tool**

Painting tools can be found under Rendering.
The 3D Paint tool is a texture based tool let’s you create a texture by painting pixels in real time on a 3D model.

The 3D Paint tool uses pixels based brushes.
The Paint Effects tool is a 3D model based tool that lets you apply three dimensional brush strokes that can follow the surface of a 3D model. The Paint Effect tool uses 3D based brush strokes: for example vines

For example a clump of fibers

The Paint Effect tool uses 3D based brush strokes with a smear effect. Please note that we are going to apply both tools on the same 3d objects.
**A- Painting with the 3D Paint tool**

In Rendering, make sure that your object is selected, press the “Select by Object Type” button, object shows up with green lines.

- Step 1, go to Texturing > 3D Paint Tool, select the options tool.
- Step 2, go to the attribute window on the right.
- Please note that you can’t paint on the 3D object without assigning a texture.

Before assigning a texture, an “X” shows up across the interactive brush in the perspective view. After assigning a texture, an “circle” shows up around the interactive brush in the perspective view.
Step 3, scroll down until you find: File Textures > Assign/Edit Textures, go to the Assign/Edit Textures window, select the size of the texture 1024.1024.
Step 4, paint with the brush on the 3D object. The brush is inside a red circle. Go to the 3D Paint window to change the brush radius. Select Browse to upload a brush made of the jpg image of your choice.

**IMPORTANT NOTE:**
You may need to track down the texture image that you created with the 3D Paint Tool. The image is saved inside a 3D Paint folder in the same data folder than your scene.

Go to Windows > Rendering Editors > Hypershade

This illustration shows how to retrieve the path of the texture created in 3D Paint or how to upload a texture before painting on it. Virtools users, the jpg texture needs to be saved in your data resource > textures folder when you create
B- Painting with the 3D Paint tool

The Paint Effect Tool lets you generate a 3D object that snaps to the surface of the head. In Rendering, make sure that the object is selected, press the "Select by Object Type" button, object shows up with green lines.

Step 1, go to Paint Effects > Make Paintable
Step 2, go to Paint Effects > paint Effects Tool, select the options tool.
Step 3, go to Window > General Editor > Visor, select the PaintEffects tab, choose a painting brush.
Step 4, go to Paint Effects > Template Brush Settings, resize the brush.

Painting with a “Smear” type of brush. You can achieve dissolve or nudge effects by changing brush type.
**IMPORTANT NOTE:** Please keep in mind that you can easily crash 3D interactive projects or renderings when creating too many objects or very complex with the Paint Effects tool.

For example 3D interactive projects using trees or patches of grass:
Each brush stroke of grass may or may not add a large amount of faces to your scene. Using the “treeMesh” gives better results than the “trees” section. I suggest that you stay away from creating multiple patches of grass or multiple trees in Maya. For example for grass, importing large amounts of blade of grass or of trees can ruin the performance of a virtual world. Importing one blade of grass or one tree is enough, cloning blades of grass or cloning trees in a virtual world is the way to go.

For rendering projects using trees or patches of grass:
Close up shots of trees or grass may increase rendering time, ask yourself how much do you really need of these elements in your scene. Plan a scene with lots of grass for long distance shots and a scene with a single patch of grass for close up shots.
…hiding the sphere and rendering only the fire. If you paint on the surface of a head you can render a goofy head by making the sphere invisible.

Let's hide a 3D object so it won't show in your rendering.

For example, you can paint on a billboard, then hide the billboard and only show the brush strokes in your rendering.

Step 1, display the layers window
Step 2, create a new layer. Select an 3D object in the perspective view and right click on “layer1” choose “add selected object” to layer 1. Click on “V” in order to make the layer invisible.
Part 5- Export to Virtools
If you are exporting the terrain assignment to Virtools, please check the following steps.
This fantastic city was created by painting with the CityMesh > skyscraper brush over a terrain. CityMesh can be found in Window > General Editor > Visor > PaintEffects. The skyscrapers are pressure sensitive, they snap to the terrain and follow the slope of the terrain.

**Part 4 - Export to Virtools (For Virtual Spaces applications)**

Let's export to Virtools the buildings and the terrain:
Exporting the buildings brush strokes

**A- Ungroup**
Step 1 go to window > Outliner, select the brush stroke that you want to export. Skip the following step, if your simple brush stroke is not a group.

If you find a group, for example for a tree brush stroke. A tree will have a trunk brush, branches brushes, leaves brushes. You need to ungroup the brush stroke. A complex 3D brush, for example a “skyscraper” brush is made of several elements of skyscraper can be made of several small brushes base, shaft, top.

In case the brush stroke is a group called MeshGroup. In Outliner, select MeshGroup, go to Edit > Ungroup

**B- Convert to polygons**

Export PaintEffects meshes: In Outliner select one of the brush strokes, go to Modify > Convert > PaintEffects to Polygons. Repeat the same for each brush stroke.
Export NURBS meshes: In Outliner select the mesh for the terrains, go to Modify > Convert > NURBS to Polygons. Repeat the same for each object made of NURBS.

Monitor the number of polygons, go to Display > Heads Up Display > Polygon Count. When you reach about **more than 10000 polygons**, you need to lower the polygonal count. Undo the conversion and delete some brush strokes or keep the conversion and delete some polygonal buildings.

Skip the following step, if your simple brush stroke is not a group.

In the case of complex brush strokes, I suggest that you combine all the parts of the buildings – base, shaft, top - together into one mesh. Hold shift and select all the parts, go to Polygons > Combine.

**C – Export to Virtools**

Exporting meshes:
In Outliner, select each mesh for the brush strokes and for the terrain, go to File > Export Selection and Export to the data Resource > 3D Entities folder that you created in Virtools. Please note that you can export selected brush strokes and terrain one by one or that you can export all the scene at once.

Exporting textures, the Maya2Virtools exporter does a good job exporting textures in your data resource > Textures folder.
In some cases, the exporter can’t not track down complex paths – for example when using a server. You need locate and copy/paste manually some textures created and used in the scene.

**To track down 3D Paint textures created in Maya**
To track down PaintEffects textures used with Visor Brush strokes

Go to Window > Rendering Editors > Hypershade > Materials. Right click on the shaders icons, select Graph Network. Double click on the File text Open the Find the location of the texture in
the texture attribute window. Copy paste the texture from the Maya folder to the data Resource >
Textures folder that you created in Virtools.

Please note that you may not need to copy all the textures. In this case only one texture is
needed for the shaft.